I am trying to install some extensions via composer, however, the installation fails every time for some reason.
I am trying to make sense of the response but couldn't understand.
- Problem 1:
composer needs extension version ^0.3.1 or above? and has extension 0.3.1?
- Problem 2:
extension needs flarum ^0.1.0-beta.15 or above and has found flarum v0.1.0-beta.15 ? and is not updated/upgraded enough for installation.
Here's my console:
firstname.lastname@example.org [~]# composer require fof/recaptcha
Using version ^0.3.1 for fof/recaptcha
./composer.json has been updated
Running composer update fof/recaptcha
Loading composer repositories with package information
Your requirements could not be resolved to an installable set of packages.
- Root composer.json requires fof/recaptcha ^0.3.1 -> satisfiable by fof/recaptcha[0.3.1].
- fof/recaptcha 0.3.1 requires flarum/core ^0.1.0-beta.15 -> found flarum/core[dev-master, v0.1.0-beta.15, 0.1.x-dev (alias of dev-master)] but it does not match your minimum-stability.
Installation failed, reverting ./composer.json to its original content.