[shareourfun@li1368-227 forum]$ composer require extiverse/mercury:*
./composer.json has been updated
Running composer update extiverse/mercury
Loading composer repositories with package information
Your requirements could not be resolved to an installable set of packages.
- extiverse/mercury[0.1.2, ..., 0.1.3] require extiverse/api-client 0.2.1 -> satisfiable by extiverse/api-client[0.2.1, 0.2.2, 0.2.3].
- extiverse/mercury[0.1, ..., 0.1.1] require extiverse/api-client 0.2 -> satisfiable by extiverse/api-client[0.2, 0.2.1, 0.2.2, 0.2.3].
- extiverse/api-client[0.2, ..., 0.2.3] require guzzlehttp/psr7 1.8.* -> found guzzlehttp/psr7[1.8.0, 1.8.1, 1.8.2] but the package is fixed to 2.0.0 (lock file version) by a partial update and that version does not match. Make sure you list it as an argument for the update command.
- Root composer.json requires extiverse/mercury * -> satisfiable by extiverse/mercury[0.1, 0.1.1, 0.1.2, 0.1.3].
Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.
Installation failed, reverting ./composer.json and ./composer.lock to their original content.