My PHP is already 7.3 but why showing this error?
flarum/core[v1.2.0, ..., v1.2.1] require php >=7.3 -> your php version (7.2.34) does not satisfy that requirement.
Captain01012 sometimes php versions are different between the command line (cli/ssh) and the website. You can probably configure the commandline php version in your control panel or access another php version using a different binary (eg php74 composer ...).
php74 composer ...
I am not an expert in ssh can you send me the ssh command line to fix this issue?
Are you on shared hosting? Select PHP 8.0 or 8.1 in the version selector in the control panel.
I have already changed my PHP version to 7.3 but not working but PHP file shows 7.3