# composer require overtrue/flysystem-qiniu
Using version ^2.0 for overtrue/flysystem-qiniu
./composer.json has been updated
Running composer update overtrue/flysystem-qiniu
Loading composer repositories with package information
Your requirements could not be resolved to an installable set of packages.
- Root composer.json requires overtrue/flysystem-qiniu ^2.0 -> satisfiable by overtrue/flysystem-qiniu[2.0.0].
- overtrue/flysystem-qiniu 2.0.0 requires league/flysystem ^2.0 -> found league/flysystem[2.0.0, ..., 2.1.1] but the package is fixed to 1.1.4 (lock file version) by a partial update and that version does not match. Make sure you list it as an argument for the update command.
Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.
Installation failed, reverting ./composer.json and ./composer.lock to their original content.